Connect with us




[Risolto] DNS Zeroshell - Laboratorio Penetration Testing  

  RSS

seawolf
(@seawolf)
Active Member
Registrato: 11 mesi fa
Post: 5
25/03/2018 7:36 pm  

Ciao a tutti, volevo sapere se qualcuno ha incontrato difficoltà nel configurare la zona DNS di Zeroshell seguendo i passaggi della rivista N. 217.

Io dopo aver configurato tutto e verificati i passaggi non riesco a far risolvere l'indirizzo dell'esempio al browser di Kali, mentre lo raggiungo tranquillamente inserendo l'indirizzo IP nella barra degli indirizzi.

Avete qualche idea?

 


RispondiQuota
Whistler
(@whistler)
Trusted Member
Registrato: 12 mesi fa
Post: 57
26/03/2018 12:54 pm  

Ciao! Anch'io ho riscontrato lo stesso problema e sto cercando di risolverlo da qualche settimana.

Credo che il problema riguardi la configurazione di Zeroshell perché il comando dato sulla macchina "Pentester" per modificare il file /etc/resolv.conf è senza dubbio corretto (salvo errori di battitura da parte dell'utente ovviamente).

Nel configurare la zona DNS su Zeroshell ho notato che mentre inserisco dati quali ip dellla macchina "router", l'indirizzo e-mail e il nome del dominio, appena confermo l'inserimento, alcuni campi cambiano da soli  (l'ip della macchina router, "212.100.1.1" diventa "212.100.1.1." ovvero si aggiunge magicamente un punto alla fine del campo; l'e-mail da "[email protected]" cambia in "root.labpentest.hj.", i punti magici ora sono due! ; alla fine del nome di dominio compare un altro punto, da "labpentest.hj" a "labpentest.hj.").

Personalmente non so se questi cambiamenti siano normali e la causa del problema sia attribuibile a qualcos'altro.

Questo fenomeno si è verificato anche a te?

Appena ho un po' di tempo scriverò su un nuovo topic un riepilogo di tutti i passaggi svolti in quanto questo è l'unico modo per consentire ad un altro utente del forum di provare a capire se ci sono stati degli errori nel seguire la procedura descritta nei numeri della rivista.

Mi dispiace non aver trovato ancora una soluzione al problema e spero di esserti stato d'aiuto.

Buona fortuna!


RispondiQuota
Massimiliano Zagaglia
(@staffhj)
Utenti Admin
Registrato: 1 anno fa
Post: 8
26/03/2018 4:59 pm  

Ciao, ho appena chiesto all'autore dell'articolo.

Purtroppo io sono in partenza e fino a giovedì prossimo non ho modo di provare, spero che mi arrivi prima la risposta dall'autore...


RispondiQuota
seawolf
(@seawolf)
Active Member
Registrato: 11 mesi fa
Post: 5
28/03/2018 11:45 am  
Posted by: Massimiliano Zagaglia

Ciao, ho appena chiesto all'autore dell'articolo.

Purtroppo io sono in partenza e fino a giovedì prossimo non ho modo di provare, spero che mi arrivi prima la risposta dall'autore...

Perfetto grazie!


RispondiQuota
seawolf
(@seawolf)
Active Member
Registrato: 11 mesi fa
Post: 5
28/03/2018 11:48 am  
Posted by: Whistler

Nel configurare la zona DNS su Zeroshell ho notato che mentre inserisco dati quali ip dellla macchina "router", l'indirizzo e-mail e il nome del dominio, appena confermo l'inserimento, alcuni campi cambiano da soli  (l'ip della macchina router, "212.100.1.1" diventa "212.100.1.1." ovvero si aggiunge magicamente un punto alla fine del campo; l'e-mail da "[email protected]" cambia in "root.labpentest.hj.", i punti magici ora sono due! ; alla fine del nome di dominio compare un altro punto, da "labpentest.hj" a "labpentest.hj.").

Ciao, per quanto riguarda i punti che sostituiscono la "@" e il resto è del tutto normale. Comunque speriamo di trovare una soluzione per tutto il resto. 🙂


RispondiQuota
Massimiliano Zagaglia
(@staffhj)
Utenti Admin
Registrato: 1 anno fa
Post: 8
29/03/2018 4:37 pm  

Ciao, scusate il ritardo, ero in trasferta senza quasi accesso a Internet...

Ecco la soluzione:
Zeroshell dispone di alcune features di sicurezza built-in (altro che Windows, eppure è una distribuzione pensata per ambienti embedded), per cui consente l'accesso al server DNS solo ai client abilitati.

Purtroppo questa informazione è stata dimenticata nell'articolo, ma ecco come rimediare.
Dalla schermata principale di configurazione del DNS, occorre premere il tasto "Clients" (è un pulsante blu, posto in alto appena sotto il pannello con le caratteristiche generali della macchina). Nel campo IP della finestra che apparirà in pop-up, è sufficiente inserire il valore 210.100.1.0/24 (la subnet su cui è attestata la VM pentester), poi premere prima il pulsante +, quindi il tasto "Save".

Così dovrebbe andare tutto a posto. Ci fate sapere, per favore, se riuscite?


ecate hanno apprezzato
RispondiQuota
Whistler
(@whistler)
Trusted Member
Registrato: 12 mesi fa
Post: 57
29/03/2018 8:51 pm  

Grazie della dritta! Provo immediatamente e ti faccio sapere. ? 


RispondiQuota
Whistler
(@whistler)
Trusted Member
Registrato: 12 mesi fa
Post: 57
29/03/2018 9:17 pm  

Funziona! Ho effettuato le modifiche su Zeroshell e dato i comandi indicati sulla rivista, (dig labpentest.hj NS ; dig labpentest.hj SOA; dig labpentest.hj A; fierce -dns labpentest.hj) tutti andati a buon fine e coerenti con le descrizioni dell'articolo.

È emozionante seguire questo corso e la vostra rivista!

Grazie ancora.


RispondiQuota
seawolf
(@seawolf)
Active Member
Registrato: 11 mesi fa
Post: 5
04/04/2018 10:33 am  
Posted by: Massimiliano Zagaglia

Ciao, scusate il ritardo, ero in trasferta senza quasi accesso a Internet...

Ecco la soluzione:
Zeroshell dispone di alcune features di sicurezza built-in (altro che Windows, eppure è una distribuzione pensata per ambienti embedded), per cui consente l'accesso al server DNS solo ai client abilitati.

Purtroppo questa informazione è stata dimenticata nell'articolo, ma ecco come rimediare.
Dalla schermata principale di configurazione del DNS, occorre premere il tasto "Clients" (è un pulsante blu, posto in alto appena sotto il pannello con le caratteristiche generali della macchina). Nel campo IP della finestra che apparirà in pop-up, è sufficiente inserire il valore 210.100.1.0/24 (la subnet su cui è attestata la VM pentester), poi premere prima il pulsante +, quindi il tasto "Save".

Così dovrebbe andare tutto a posto. Ci fate sapere, per favore, se riuscite?

Buongiorno, sono riuscito a provarlo soltanto oggi. Adesso funziona! Grazie per la dritta.

Modifico il topic in risolto.


RispondiQuota
Pag. 1
(@fifojr)
New Member
Registrato: 3 settimane fa
Post: 2
31/01/2019 7:10 pm  

Ciao ho provato a connettermi a http://www.labpentest.hj   da Kali ma non sono riuscito nonostante abbia aggiornato la voce Client. => Bash: http://www.labpentest.hj: No such file or directory. Per quanto riguarda il comando dig funziona fino in fondo alla sezione della rivista. Ps le macchine comunicano.

Cosa ricontrollare ? Grazie


RispondiQuota
Share:

IN EDICOLA

  
Working

Please Login or Registrazione